Contenido funktioniert nicht mit PHP 5.3

 Contenido funktioniert nicht mit PHP 5.3

13.08.2009, 17:13:12 Uhr - Ortwin Pinke

Mit der neuerdings immer öfter vorinstallierten PHP-Version 5.3 läuft das aktuelle Contenido 4.8.12 und seine Vorgänger nicht bei einer Standardinstallation.

Die Gründe dafür liegen nicht direkt an Contenido, sondern hauptsächlich an der doch schon recht betagten PHPLib. Diese stammt noch aus PHP3 Zeiten und verwendet in den MySQL-Teilen Funktionen, die von PHP 5.3 nicht mehr unterstützt werden, bzw. als deprecated gekennzeichnet sind.

Um Contenido 4.8.12 trotzdem zu verwendet, sollte man als DB-Layer nicht den MySQL-Treiber, sondern den MySQLi-Treiber der PHPLib verwenden. Das ist für eine Neuinstallation zur Zeit nur direkt in der Datei conlib/prepend.php möglich.
Auserdem muss natürlich die MySQLi-Erweiterung von PHP aktiv sein.

Wir überarbeiten im Moment die PHPLib um sie PHP 5.3 kompatibel auch im Bereich MySQL zu machen. Weitere Info's zum Thema findet man auch im Forum unter http://forum.contenido.org/viewtopic.php?f=63&t=24032

Bisherige Kommentare:

{FIELD_NAME} schrieb:
Uhr

{FIELD_COMMENT}

Kommentar schreiben

Name:
E-Mail Adresse:
Kommentar: